„Intel“ atskleidė, kad dauguma jų procesorių yra paveikti keturių naujų saugumo pažeidžiamumų. Jie yra – „ZombieLoad“, „Fallout“, RIDL („Rogue In-Flight Data Load“) ir „Store-to-Leak Forwarding“. Šios problemos vėl susijusios su „HyperThreading“ technologija. Reikia paminėti, kad šių pažeidžiamumų neturi 8 ir 9 kartos „Core“ procesoriai, o taip pat 2 kartos „Xeon Scalable“ procesoriai. Juose jau integruoti pataisymai techniniu lygiu. Kitiems procesoriams bus teikiami pataisymai mikrokodo arba operacinės sistemos atnaujinimo pavidalu. Suprantama, tai ir vėl turės neigiamos įtakos spartai tam tikrose užduotyse.

Norint apsisaugoti nuo naujų pažeidžiamumų operacinių sistemų kūrėjai turės pakeisti „HyperThreading“ veikimą. Kiekvienai gijai bus suteikiamas papildomas sluoksnis, kad viena gija negalėtų matyti ką daro kita. Nors tai nėra didelė problema naudojantis asmeniniu kompiuteriu, bet debesų ar serverių versle viskas yra kitaip. Tokie atnaujinimai neigiamai įtakos spartą, nes paprasčiausiai visos gijos negalės būti išnaudojamos pilnai. Tai vyks tada kai veikia kelios programos, o operacinė sistema joms neleis matyti kas vyksta kitoje gijoje. Dėl to nebus galima tinkamai paskirstyti apkrovos.

Norint atsikratyti pažeidžiamumų „Intel“ tiesiog siūlo išjungti „HyperThreading“ technologiją.


Parašykite komentarą

El. pašto adresas nebus skelbiamas. Būtini laukeliai pažymėti *